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This class will show you how to make your Revit families stretch with grip handles
that are visible in 3D and conftrollable like never before.
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Traditional Methods to Family Creation

Anyone who knows how to build Revit families is familiar with the ever-popular reference plane.
These are often referred to as “the bones” of a parametric family. Reference planes allow for use
to add parameters that in turn control geometry within the family.

Reference Planes

To add parameters to families, we will typically utilize reference planes. This
involves drawing the reference planes in a 2d view, (plan view, elevation, etc.).
within the family editor. Once we add the reference planes, we can “snap”
geometry to them. After this is complete we can add dimensions and turn them
into parameters. The result looks like this out of the box countertop below. (This
process is not completely broken down as this is covered in other classes.)
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OOTB Countertop Using Traditional Methods.

Overall, reference planes are a solid tried and true method to creating families. Next, we will cover some
of the opportunities surrounding this method, then we will challenge this thinking.

Control Location of Grips in the Project Environment

Utilizing a reference plane based grip handle method results in the inability to control the location of the
resulting grips in the project environment.
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OOTB Counter Top in Project Environment.

Availability in 3D Views

Most of us are working in 3D when we are in Revit. Why are our grip handles not available in these view
for us? The reason is, we typically use reference planes which are only visible in views that are not 3D
and intersect the extents of the reference plane in perpendicular views.
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OOTB Countertop Using Revised Methods.

Control Visibility of Grips in the Project Environment



Additionally, reference plane-based grip handles are always present. Even when you don’t need them.
Wouldn’t it be nice to turn off the grip handles when you do not need to use them?
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Addition of Grip Handle Visibility Parameter.

Revising the OOTB Countertop Family.

First, we start off by fixing something that is missing in the OOTB Countertop Family. We want the grip
handles to be on the actual geometry that they control. Rather than centered as previously discussed.

First, Activate the Family

First, open the file named, Session 3.2__01-O0TB-Family-Begin.rvt. To activate the family, simply double
click the counter top to open the family editor.
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Familiarize Yourself with the Conditions

Next, we will navigate to the view, Ground Floor. Right away, we can see that this family is complete
utilizing the Reference plane method. Since this is already done for us, we will leave them in place. The

remaining issue is the location of the resulting grip handles, lets fix that.

Utilize Another Tool

Since we are leaving the reference Planes in place for now, we can go ahead and use another tool in its
place. For locatable grip handles, our first method is reference lines.
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Creates a reference line that you can use when creating a new
mass, or to create constraints for the mass.
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Draw a reference line just as
you would any other datum
element. In our case, we will
draw slightly beyond the
table and align it in place.

We can align the endpoints to the
reference planes and draw a new - W
dimension string to constrain them.
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If we load this family in the project environment, we will notice that two sets of grip handles now exist!
(The grips located on the corresponding geometry are our new ones.)
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Old grip handles are still available in 2D

Next, lets fix those old reference plane-based ones.

Back in the family editor now, we can choose the reference planes that previously controlled the legs of
the table. Here, we can change the “Is Reference” property to “Not a Reference”.



Properties x

Length - Leg 1= 8- 0

L
Multiple Families Selected - /‘
i | tengtn-Leg 1= o
Reference Planes (2) ~| B8 Edit Type T |
Construction A ! | |
Wall Closure O 1 | .
Extents B == : I
Scope Box None | !
Identity Data I !
Name = |
Subcategory <Nones 2 !
her A o
s Reference [Not a Reference. |
Thes Origin g e o
|
|
[ | I ) [
| 1
s s = ! ! !
@ @ 7 | |
" " <
S & ! | b
5 08 --p---——-¢- |
5| B = b
3 3
- -

Changing Reference Plane Type

Load the family back in the project once again. Now, we can see that these old versions are now gone!
Additionally, we have 3D grip handles now as well.
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Old grips are now gone!
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OOTB Countertop Fixed with 3D Grips in Great Locations.

This method is great, it gave us nicely located 3d grip handles but, it can be even better! Next, we will
learn how to add visibility toggles to 3d grip handles.

Visibility for Grip Handles

Using a similar thought from the previous example, we are going to give our grip handles the ability to
be turned on and off with a visibility parameter.



Next, we are going to remove the reference lines we previously created. This will also get rid of the
dimensions that we added. This is ok, as we are going to rebuild this logic using model lines.
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Replacing Reference Lines with Model Lines.

Now, if we load this into the project environment, we will see comparable results as before. One key
difference is, we can now see the lines as well as the grip handles.
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To fix this, let’s go back to the family editor and use a different line style.



Within the family editor, we can choose “Invisible Lines”. This will hide the model geometry of the lines,
but the grip handles will stay.

[ 7 DI D i o — [(\'31«"' (=1 @ [ save iy i
te & |:| &L e b e ] & subcategory: o Lg(ﬁf > = Nd ]| LS
neBr Gty O3 O =5, on b : Casework [projection] _ ~| Convert Visibility  Edit Filter Loadinto  Load into
v Q9 (L= == [Coseworklprojection] ]| Umes  Settings Work Plane Project Project snd Close
ometry Modify Measure Creste oo Edit  Visibility  WorkPlane Placement Selection Family Editor

Counter Top [projection]

Properties x Counter Top [cut] Lenoth - Lag 128+ 0
! angth - Leg 15
= Hidden Lines [projection]
' Hidden Lines [cut] Lot Lea 1o
angth Leg 1=
<Invisible lines> ] ; [
Lines (Casework) (2] - | : I
Constraints ] | |
Work Plane Reference Plane: Top Of C...! ! |
Graphics B = f 7
Visible I |
Vicibility/Graphics Overrides Fait. ] i I |
Dimensions A = |
Length z1 ‘ i
dentity Data 2 g
Subcategory Casework [projection] &
Other %
Reference Weak Reference :
Model or Symbolic Model Lines
| | |
= = . I I
- =
= = K | |
i 0 <
& & | |
m =
z z
3 N — - |
£ g s I
2 2
g g
g 5
L
I

Model Lines Changed to Invisible Line Style.

While we are at it, we can go ahead and select both model lines and add a visible parameter to them.
Visibility can be added after selecting both model lines and choosing the ellipsis button in the properties
palette.
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Addition of Visibility Parameter to Model Lines.
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Create Visibility Parameter Dialogue.

Now, if we load this family back into the project environment, we can control the visibility of the grip

handles!
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Visibility for Grips.
Rotation Methods in Conjunction with 3D Grips

Rotating Revit families is a very love/hate relationship. In fact, there are a number of other classes to
remedy this common frustration. If we add in 3D grip handles, this combination proves to be even more

powerful. Next, we will make an operable door with 3d grips.



Building a Great Operable Door

First, we need to make a door family to control with our new-found methods. Go ahead and navigate to
File>New>Family>Door.rft

Immediately after this, we can go ahead and start a new profile family as well by navigating to
File>New>Family>Profile.rft (This profile will serve as a geometry host for door components.)

In this profile family, we can draw a simple box, save as “Sweep-Host”, and load into the door family.
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Simple “Host” Sweep Family.

To use this host sweep family, we will navigate to the exterior elevation view and set our workplane as
exterior.



roject Browser - Familyl X Properties x

5.0 Views (all)
- Floor Plans
Ref. Level !
- Ceiling Plans
Ref. Level
55 3D Views

Farmily: Doors °
Constraints
View Host iWall

€]
&~ Blevations (Elevation 1)
Exterior

Identity Data
o

lass Number 3.30.10.00
Titie Doors

Work Plane X

Interior
Left
Right
Sheets (all)
2 B Families
) Annotation Symbols

Current Work Piane

Exterior

Reference Plane : Center (LeftfRight)

100K

Show

1

I

-+

I

1

|

1

1

1

I

I

- Profiles Specify anew Work Plane X
& Family2

Family2 @ Name Reference Plane : Left v |
@ Sweep-Host Opickaplane JE IV

- Walls ;

o-[e] Groups ,

& RevitLinks X

1

1

1

|

1

I

1

I

1

1

I

I

1

(Orpickaline and use the work plane it was sketched in

_ o _ . Ref Level
o or

(N

i

Setting Your Workplane.

Now that we have our workplane set, lets draw a reference line to host our new sweep. We will also
snap this reference line to the top, bottom and right side of the door template.
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Constrained Reference Line.

Now, we navigate to 3D and fix our view scale to create a sweep, (3” = 1’-0” seems to work well). Now,
we can isolate our reference line to make life easier.
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Now, we can finally add the sweep by navigating to Create > Sweep. We will choose pick path and select

our reference line. Then select our profile that we created previously.

Creation of a Sweep Component.

——

X | of
Qy Pick 3D
Edges

:asure Create  Mode  Pick

* | Temporary Hide/lsclate

Modify | Sweep

“Host” Sweep Marked as Invisible.

s . 3% @ @ﬂj % Profile:
u el <By Sketch>
Set  Show Viewer @q : Select
2 \f\ - L PickPath bt  <By Sketch>
Measure Create  Mode Work Plane [weep-tost |,
Flip || Apply
* | Temporary Hii
5
- N
N .
- -~
- e
Properties x
.
I~ -
Doers (1) ~
Graphics
Visible
Visibility/Graphics Overrides. Edit...
Materials and Finishes
Material <By Category>
Identity Data
Subcategory <Mone>
Solid/Void Solid
Profile
Profile Sweep-Host : Sweep-Host
Horizontal Profile Offset [
Vertical Profile Offset [
Angle 0.00°
Profile Is Flipped O
Other
Trajectory Segmentstion [ ]
Maximum Segment Angle :360.00°
N
.




Now that we have our host family, we have access to an amazing hidden gem, the profile angle
parameter! This awesome parameter allows for unbreakable rotations in families with minimal effort.
The only downside is, in our example the angle appears to go opposite of what we want. Why is that?
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The reason for this is because the reference plane (Exterior) was originally drawn from right to left
rather than left to right. Rather than rebuilding a lot of logic, we can simply fix this in our parameters
later.

Now, we can go ahead and load in the provided panel family and host it to the sweep we created.
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And we finally have a door panel that rotates in a fantastic way.
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Sweep Rotation Controlling Panel.
Once we have the rotation working we can tie the panel parameters to the door family parameters.



